summaryrefslogtreecommitdiffhomepage
path: root/third-party/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'third-party/CMakeLists.txt')
-rw-r--r--third-party/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/third-party/CMakeLists.txt b/third-party/CMakeLists.txt
new file mode 100644
index 0000000..2c9f2f1
--- /dev/null
+++ b/third-party/CMakeLists.txt
@@ -0,0 +1,30 @@
+include(ApplyPatch)
+include(FetchContent)
+include(MakeAvailable)
+add_subdirectory(gtest)
+add_subdirectory(infoware)
+add_subdirectory(libpng)
+add_subdirectory(ogg)
+add_subdirectory(vorbis)
+add_subdirectory(zlib)
+make_available(gtest infoware libpng ogg vorbis zlib)
+add_subdirectory(Opcode)
+add_subdirectory(sha1)
+install(
+ TARGETS png15 Opcode
+ RUNTIME
+ COMPONENT Runtime
+ DESTINATION ${CMAKE_INSTALL_PREFIX}
+ )
+if(NOT MSVC)
+ foreach(LIB IN ITEMS "libstdc++-6.dll" "libwinpthread-1.dll" "libgcc_s_dw2-1.dll")
+ find_file(LIBRARY_${LIB} ${LIB} PATHS ${CMAKE_FIND_ROOT_PATH}/bin)
+ if(LIBRARY_${LIB})
+ install(
+ PROGRAMS ${LIBRARY_${LIB}}
+ COMPONENT Runtime
+ DESTINATION ${CMAKE_INSTALL_PREFIX}
+ )
+ endif()
+ endforeach()
+endif()