summaryrefslogtreecommitdiffhomepage
path: root/third-party/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2024-03-12 22:07:03 +0100
committerAki <please@ignore.pl>2024-03-12 22:07:36 +0100
commit81bb6873f1c0291fecbf6e429ad15ac3db66a4c0 (patch)
treefd7552ecabeeffb45a1fbe3730ab62bc7a64dd85 /third-party/CMakeLists.txt
parentf43d32d6d2cc7ecd04f4f06f20d5a6fc2c87c9ae (diff)
downloadstarshatter-81bb6873f1c0291fecbf6e429ad15ac3db66a4c0.zip
starshatter-81bb6873f1c0291fecbf6e429ad15ac3db66a4c0.tar.gz
starshatter-81bb6873f1c0291fecbf6e429ad15ac3db66a4c0.tar.bz2
Legal notices updated
Rename contrib -> third-party intendes to express the origin and purpose of that part of the code better. I plan to readd contrib/ again but with more in-project things like bash-completions, dev workflow scripts etc.
Diffstat (limited to 'third-party/CMakeLists.txt')
-rw-r--r--third-party/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/third-party/CMakeLists.txt b/third-party/CMakeLists.txt
new file mode 100644
index 0000000..2c9f2f1
--- /dev/null
+++ b/third-party/CMakeLists.txt
@@ -0,0 +1,30 @@
+include(ApplyPatch)
+include(FetchContent)
+include(MakeAvailable)
+add_subdirectory(gtest)
+add_subdirectory(infoware)
+add_subdirectory(libpng)
+add_subdirectory(ogg)
+add_subdirectory(vorbis)
+add_subdirectory(zlib)
+make_available(gtest infoware libpng ogg vorbis zlib)
+add_subdirectory(Opcode)
+add_subdirectory(sha1)
+install(
+ TARGETS png15 Opcode
+ RUNTIME
+ COMPONENT Runtime
+ DESTINATION ${CMAKE_INSTALL_PREFIX}
+ )
+if(NOT MSVC)
+ foreach(LIB IN ITEMS "libstdc++-6.dll" "libwinpthread-1.dll" "libgcc_s_dw2-1.dll")
+ find_file(LIBRARY_${LIB} ${LIB} PATHS ${CMAKE_FIND_ROOT_PATH}/bin)
+ if(LIBRARY_${LIB})
+ install(
+ PROGRAMS ${LIBRARY_${LIB}}
+ COMPONENT Runtime
+ DESTINATION ${CMAKE_INSTALL_PREFIX}
+ )
+ endif()
+ endforeach()
+endif()