summaryrefslogtreecommitdiffhomepage
path: root/contrib/zlib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/zlib/CMakeLists.txt')
-rw-r--r--contrib/zlib/CMakeLists.txt12
1 files changed, 0 insertions, 12 deletions
diff --git a/contrib/zlib/CMakeLists.txt b/contrib/zlib/CMakeLists.txt
index c3d75e8..247f499 100644
--- a/contrib/zlib/CMakeLists.txt
+++ b/contrib/zlib/CMakeLists.txt
@@ -60,18 +60,6 @@ if(MSVC)
include_directories(${CMAKE_CURRENT_SOURCE_DIR})
endif()
-if(NOT CMAKE_CURRENT_SOURCE_DIR STREQUAL CMAKE_CURRENT_BINARY_DIR)
- # If we're doing an out of source build and the user has a zconf.h
- # in their source tree...
- if(EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/zconf.h)
- message(STATUS "Renaming")
- message(STATUS " ${CMAKE_CURRENT_SOURCE_DIR}/zconf.h")
- message(STATUS "to 'zconf.h.included' because this file is included with zlib")
- message(STATUS "but CMake generates it automatically in the build directory.")
- file(RENAME ${CMAKE_CURRENT_SOURCE_DIR}/zconf.h ${CMAKE_CURRENT_SOURCE_DIR}/zconf.h.included)
- endif()
-endif()
-
set(ZLIB_PC ${CMAKE_CURRENT_BINARY_DIR}/zlib.pc)
configure_file( ${CMAKE_CURRENT_SOURCE_DIR}/zlib.pc.cmakein
${ZLIB_PC} @ONLY)