summaryrefslogtreecommitdiffhomepage
path: root/contrib/zlib/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2024-03-03 01:05:28 +0100
committerAki <please@ignore.pl>2024-03-03 01:05:28 +0100
commit54fa233a00607b9436c03c78b50b9107a33baa0a (patch)
tree58dd5bb7f229be4b3099a6e63615a477d62a2ce6 /contrib/zlib/CMakeLists.txt
parente70158ea57302e2fa2d588b67fc8dc18265192eb (diff)
downloadstarshatter-54fa233a00607b9436c03c78b50b9107a33baa0a.zip
starshatter-54fa233a00607b9436c03c78b50b9107a33baa0a.tar.gz
starshatter-54fa233a00607b9436c03c78b50b9107a33baa0a.tar.bz2
Remove zconf.h to prevent all builds be -dirty
Diffstat (limited to 'contrib/zlib/CMakeLists.txt')
-rw-r--r--contrib/zlib/CMakeLists.txt12
1 files changed, 0 insertions, 12 deletions
diff --git a/contrib/zlib/CMakeLists.txt b/contrib/zlib/CMakeLists.txt
index c3d75e8..247f499 100644
--- a/contrib/zlib/CMakeLists.txt
+++ b/contrib/zlib/CMakeLists.txt
@@ -60,18 +60,6 @@ if(MSVC)
include_directories(${CMAKE_CURRENT_SOURCE_DIR})
endif()
-if(NOT CMAKE_CURRENT_SOURCE_DIR STREQUAL CMAKE_CURRENT_BINARY_DIR)
- # If we're doing an out of source build and the user has a zconf.h
- # in their source tree...
- if(EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/zconf.h)
- message(STATUS "Renaming")
- message(STATUS " ${CMAKE_CURRENT_SOURCE_DIR}/zconf.h")
- message(STATUS "to 'zconf.h.included' because this file is included with zlib")
- message(STATUS "but CMake generates it automatically in the build directory.")
- file(RENAME ${CMAKE_CURRENT_SOURCE_DIR}/zconf.h ${CMAKE_CURRENT_SOURCE_DIR}/zconf.h.included)
- endif()
-endif()
-
set(ZLIB_PC ${CMAKE_CURRENT_BINARY_DIR}/zlib.pc)
configure_file( ${CMAKE_CURRENT_SOURCE_DIR}/zlib.pc.cmakein
${ZLIB_PC} @ONLY)