summaryrefslogtreecommitdiffhomepage
path: root/contrib/vorbis/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/vorbis/test/Makefile.am')
-rw-r--r--contrib/vorbis/test/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/contrib/vorbis/test/Makefile.am b/contrib/vorbis/test/Makefile.am
new file mode 100644
index 0000000..b68ebdb
--- /dev/null
+++ b/contrib/vorbis/test/Makefile.am
@@ -0,0 +1,19 @@
+## Process this file with automake to produce Makefile.in
+
+AUTOMAKE_OPTIONS = foreign
+
+check_PROGRAMS = test
+
+check: $(check_PROGRAMS)
+ ./test$(EXEEXT)
+
+AM_CPPFLAGS = -I$(top_srcdir)/include @OGG_CFLAGS@
+
+test_SOURCES = util.c util.h write_read.c write_read.h test.c
+test_LDADD = ../lib/libvorbisenc.la ../lib/libvorbis.la @OGG_LIBS@ @VORBIS_LIBS@
+
+debug:
+ $(MAKE) check CFLAGS="@DEBUG@"
+
+profile:
+ $(MAKE) check CFLAGS="@PROFILE@"