summaryrefslogtreecommitdiffhomepage
path: root/contrib/vorbis/test/Makefile.am
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2022-02-09 22:23:03 +0100
committerAki <please@ignore.pl>2022-02-09 22:53:55 +0100
commit373dc625f82b47096893add42c4472e4a57ab7eb (patch)
tree640228d02476d379de13071b13d1b1fa322b767f /contrib/vorbis/test/Makefile.am
parent2d7dd844219965b81e81848e60d7f7bf23035ee4 (diff)
downloadstarshatter-373dc625f82b47096893add42c4472e4a57ab7eb.zip
starshatter-373dc625f82b47096893add42c4472e4a57ab7eb.tar.gz
starshatter-373dc625f82b47096893add42c4472e4a57ab7eb.tar.bz2
Moved third-party libraries to a separate subdirectory
Diffstat (limited to 'contrib/vorbis/test/Makefile.am')
-rw-r--r--contrib/vorbis/test/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/contrib/vorbis/test/Makefile.am b/contrib/vorbis/test/Makefile.am
new file mode 100644
index 0000000..b68ebdb
--- /dev/null
+++ b/contrib/vorbis/test/Makefile.am
@@ -0,0 +1,19 @@
+## Process this file with automake to produce Makefile.in
+
+AUTOMAKE_OPTIONS = foreign
+
+check_PROGRAMS = test
+
+check: $(check_PROGRAMS)
+ ./test$(EXEEXT)
+
+AM_CPPFLAGS = -I$(top_srcdir)/include @OGG_CFLAGS@
+
+test_SOURCES = util.c util.h write_read.c write_read.h test.c
+test_LDADD = ../lib/libvorbisenc.la ../lib/libvorbis.la @OGG_LIBS@ @VORBIS_LIBS@
+
+debug:
+ $(MAKE) check CFLAGS="@DEBUG@"
+
+profile:
+ $(MAKE) check CFLAGS="@PROFILE@"