summaryrefslogtreecommitdiffhomepage
path: root/Starserver/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Starserver/CMakeLists.txt')
-rw-r--r--Starserver/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/Starserver/CMakeLists.txt b/Starserver/CMakeLists.txt
new file mode 100644
index 0000000..3142ce2
--- /dev/null
+++ b/Starserver/CMakeLists.txt
@@ -0,0 +1,14 @@
+project(Starserver)
+add_executable(
+ Starserver
+ Main.cpp
+ )
+target_include_directories(
+ Starserver
+ PRIVATE ${CMAKE_CURRENT_SOURCE_DIR}
+ )
+target_link_libraries(
+ Starserver
+ PRIVATE StarsEx
+ )
+install(TARGETS Starserver RUNTIME DESTINATION ${CMAKE_INSTALL_PREFIX})