summaryrefslogtreecommitdiffhomepage
path: root/Starserver/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2022-04-01 22:37:49 +0200
committerAki <please@ignore.pl>2022-04-01 22:41:20 +0200
commitc2199769d8f0d2b213db6f6f4349e9ebbfa0a111 (patch)
tree8ea8b24e1717a21f4821bf920c8bb31d6747491a /Starserver/CMakeLists.txt
parent3f320f31fc4f9e90302bd62208a52bfd8d3fd7c2 (diff)
downloadstarshatter-c2199769d8f0d2b213db6f6f4349e9ebbfa0a111.zip
starshatter-c2199769d8f0d2b213db6f6f4349e9ebbfa0a111.tar.gz
starshatter-c2199769d8f0d2b213db6f6f4349e9ebbfa0a111.tar.bz2
Created a stand-alone server executable
Diffstat (limited to 'Starserver/CMakeLists.txt')
-rw-r--r--Starserver/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/Starserver/CMakeLists.txt b/Starserver/CMakeLists.txt
new file mode 100644
index 0000000..3142ce2
--- /dev/null
+++ b/Starserver/CMakeLists.txt
@@ -0,0 +1,14 @@
+project(Starserver)
+add_executable(
+ Starserver
+ Main.cpp
+ )
+target_include_directories(
+ Starserver
+ PRIVATE ${CMAKE_CURRENT_SOURCE_DIR}
+ )
+target_link_libraries(
+ Starserver
+ PRIVATE StarsEx
+ )
+install(TARGETS Starserver RUNTIME DESTINATION ${CMAKE_INSTALL_PREFIX})