summaryrefslogtreecommitdiffhomepage
path: root/FoundationEx/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'FoundationEx/CMakeLists.txt')
-rw-r--r--FoundationEx/CMakeLists.txt17
1 files changed, 6 insertions, 11 deletions
diff --git a/FoundationEx/CMakeLists.txt b/FoundationEx/CMakeLists.txt
index 71dd25d..045b44e 100644
--- a/FoundationEx/CMakeLists.txt
+++ b/FoundationEx/CMakeLists.txt
@@ -1,12 +1,7 @@
project(FoundationEx)
-add_library(
- FoundationEx
- STATIC
- Reader.cpp
- Text.cpp
- Utils.cpp
- )
-target_include_directories(
- FoundationEx
- PUBLIC .
- )
+add_library(${PROJECT_NAME} STATIC src/Reader.cpp src/Text.cpp src/Utils.cpp)
+target_include_directories(${PROJECT_NAME} PUBLIC include)
+add_executable(${PROJECT_NAME}_test test/Text.cpp)
+target_link_libraries(${PROJECT_NAME}_test PRIVATE ${PROJECT_NAME} GTest::gtest_main)
+generate_emulator(${PROJECT_NAME}_test)
+gtest_discover_tests(${PROJECT_NAME}_test DISCOVERY_TIMEOUT 60)