summaryrefslogtreecommitdiffhomepage
path: root/FoundationEx/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2024-03-12 01:08:39 +0100
committerAki <please@ignore.pl>2024-03-12 01:08:39 +0100
commitf43d32d6d2cc7ecd04f4f06f20d5a6fc2c87c9ae (patch)
tree0f82962432f9cd4fae60dd37c8935c1bc28f29e5 /FoundationEx/CMakeLists.txt
parent2914a714cebae7f30d47362dfe50c39cb6621163 (diff)
downloadstarshatter-f43d32d6d2cc7ecd04f4f06f20d5a6fc2c87c9ae.zip
starshatter-f43d32d6d2cc7ecd04f4f06f20d5a6fc2c87c9ae.tar.gz
starshatter-f43d32d6d2cc7ecd04f4f06f20d5a6fc2c87c9ae.tar.bz2
Another reorganization change that diverts me from crying unable to get rid off singleton madness
Diffstat (limited to 'FoundationEx/CMakeLists.txt')
-rw-r--r--FoundationEx/CMakeLists.txt17
1 files changed, 6 insertions, 11 deletions
diff --git a/FoundationEx/CMakeLists.txt b/FoundationEx/CMakeLists.txt
index 71dd25d..045b44e 100644
--- a/FoundationEx/CMakeLists.txt
+++ b/FoundationEx/CMakeLists.txt
@@ -1,12 +1,7 @@
project(FoundationEx)
-add_library(
- FoundationEx
- STATIC
- Reader.cpp
- Text.cpp
- Utils.cpp
- )
-target_include_directories(
- FoundationEx
- PUBLIC .
- )
+add_library(${PROJECT_NAME} STATIC src/Reader.cpp src/Text.cpp src/Utils.cpp)
+target_include_directories(${PROJECT_NAME} PUBLIC include)
+add_executable(${PROJECT_NAME}_test test/Text.cpp)
+target_link_libraries(${PROJECT_NAME}_test PRIVATE ${PROJECT_NAME} GTest::gtest_main)
+generate_emulator(${PROJECT_NAME}_test)
+gtest_discover_tests(${PROJECT_NAME}_test DISCOVERY_TIMEOUT 60)