summaryrefslogtreecommitdiffhomepage
path: root/FoundationEx/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'FoundationEx/CMakeLists.txt')
-rw-r--r--FoundationEx/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/FoundationEx/CMakeLists.txt b/FoundationEx/CMakeLists.txt
index 646ee58..972a242 100644
--- a/FoundationEx/CMakeLists.txt
+++ b/FoundationEx/CMakeLists.txt
@@ -5,9 +5,11 @@ add_library(
src/Text.cpp
src/Utils.cpp
src/reader.cpp
+ src/data.cpp
+ src/reader/file.cpp
)
target_include_directories(${PROJECT_NAME} PUBLIC include)
-add_executable(${PROJECT_NAME}_test test/Text.cpp test/reader.cpp)
+add_executable(${PROJECT_NAME}_test test/Text.cpp test/reader.cpp test/data.cpp)
target_link_libraries(${PROJECT_NAME}_test PRIVATE ${PROJECT_NAME} GTest::gtest_main)
generate_emulator(${PROJECT_NAME}_test)
gtest_discover_tests(${PROJECT_NAME}_test DISCOVERY_TIMEOUT 60)