summaryrefslogtreecommitdiffhomepage
path: root/FoundationEx/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2024-03-18 23:41:20 +0100
committerAki <please@ignore.pl>2024-03-18 23:41:20 +0100
commit2066e4911948d11cac5a234d2f7773dc5f06ba96 (patch)
tree27c7672aad884d1307736b3d15e704d7d786b314 /FoundationEx/CMakeLists.txt
parent3df6ccddcbd881c2474746f5f1758b095c866a67 (diff)
downloadstarshatter-2066e4911948d11cac5a234d2f7773dc5f06ba96.zip
starshatter-2066e4911948d11cac5a234d2f7773dc5f06ba96.tar.gz
starshatter-2066e4911948d11cac5a234d2f7773dc5f06ba96.tar.bz2
Added filesystem-only starshatter::data DataLoader replacement
Step by step. The intent is to find a good spot between current data representations and the standard library and put the intermediate stage there. After it matures a bit, we can move further away.
Diffstat (limited to 'FoundationEx/CMakeLists.txt')
-rw-r--r--FoundationEx/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/FoundationEx/CMakeLists.txt b/FoundationEx/CMakeLists.txt
index 646ee58..972a242 100644
--- a/FoundationEx/CMakeLists.txt
+++ b/FoundationEx/CMakeLists.txt
@@ -5,9 +5,11 @@ add_library(
src/Text.cpp
src/Utils.cpp
src/reader.cpp
+ src/data.cpp
+ src/reader/file.cpp
)
target_include_directories(${PROJECT_NAME} PUBLIC include)
-add_executable(${PROJECT_NAME}_test test/Text.cpp test/reader.cpp)
+add_executable(${PROJECT_NAME}_test test/Text.cpp test/reader.cpp test/data.cpp)
target_link_libraries(${PROJECT_NAME}_test PRIVATE ${PROJECT_NAME} GTest::gtest_main)
generate_emulator(${PROJECT_NAME}_test)
gtest_discover_tests(${PROJECT_NAME}_test DISCOVERY_TIMEOUT 60)