summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6903cda..8797278 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,11 +28,7 @@ add_subdirectory(NetEx)
add_subdirectory(Starserver)
add_subdirectory(StarsEx)
add_subdirectory(Starshatter)
-add_custom_target(
- version ALL
- BYPRODUCTS version
- COMMAND ${CMAKE_COMMAND} -E echo "${STARSHATTER_VERSION}" >version
- )
+configure_file(version.txt.conf ${CMAKE_CURRENT_BINARY_DIR}/version.txt @ONLY)
install(
FILES NOTICE COPYING
COMPONENT Copyright