summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2022-10-17 00:45:25 +0200
committerAki <please@ignore.pl>2022-10-17 00:45:25 +0200
commit8efba10e2f8ddde86d1f0fdccac78da5814622ea (patch)
treef423ae0fbc43208d9fed892ef465b929db6f383c /CMakeLists.txt
parentfe6cf4b8b85e7eb4b8f9be11578258d06e2887e5 (diff)
downloadstarshatter-8efba10e2f8ddde86d1f0fdccac78da5814622ea.zip
starshatter-8efba10e2f8ddde86d1f0fdccac78da5814622ea.tar.gz
starshatter-8efba10e2f8ddde86d1f0fdccac78da5814622ea.tar.bz2
Switched to configure_file to consistently generate version file
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6903cda..8797278 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,11 +28,7 @@ add_subdirectory(NetEx)
add_subdirectory(Starserver)
add_subdirectory(StarsEx)
add_subdirectory(Starshatter)
-add_custom_target(
- version ALL
- BYPRODUCTS version
- COMMAND ${CMAKE_COMMAND} -E echo "${STARSHATTER_VERSION}" >version
- )
+configure_file(version.txt.conf ${CMAKE_CURRENT_BINARY_DIR}/version.txt @ONLY)
install(
FILES NOTICE COPYING
COMPONENT Copyright