summaryrefslogtreecommitdiffhomepage
path: root/third-party/l3ds/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2024-04-05 20:57:38 +0200
committerAki <please@ignore.pl>2024-04-05 20:57:51 +0200
commiteffc8802a77375437b676ac4534789e819731671 (patch)
tree4b752b61487bef73f3fce28c1f0a402f0a3ecc76 /third-party/l3ds/CMakeLists.txt
parentbeeacf69d68f366cbbc9701bb7dabd23a898c8c7 (diff)
downloadstarshatter-effc8802a77375437b676ac4534789e819731671.zip
starshatter-effc8802a77375437b676ac4534789e819731671.tar.gz
starshatter-effc8802a77375437b676ac4534789e819731671.tar.bz2
l3ds is a third party library
Diffstat (limited to 'third-party/l3ds/CMakeLists.txt')
-rw-r--r--third-party/l3ds/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/third-party/l3ds/CMakeLists.txt b/third-party/l3ds/CMakeLists.txt
new file mode 100644
index 0000000..89c13d2
--- /dev/null
+++ b/third-party/l3ds/CMakeLists.txt
@@ -0,0 +1,4 @@
+project(l3ds)
+add_library(${PROJECT_NAME} SHARED l3ds.cpp)
+target_include_directories(${PROJECT_NAME} PUBLIC include)
+install(TARGETS ${PROJECT_NAME} RUNTIME COMPONENT Runtime DESTINATION ${CMAKE_INSTALL_PREFIX})