summaryrefslogtreecommitdiffhomepage
path: root/contrib/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2024-03-03 12:51:03 +0100
committerAki <please@ignore.pl>2024-03-03 12:51:03 +0100
commit8e94244f86e657e4113e35438e59cf5771882b25 (patch)
treeb4a84a732f7f29abc8b6a129f51e406c101e7f77 /contrib/CMakeLists.txt
parentdad0e8562c8e5994fcf2ebedac5a7ec920297d1f (diff)
downloadstarshatter-8e94244f86e657e4113e35438e59cf5771882b25.zip
starshatter-8e94244f86e657e4113e35438e59cf5771882b25.tar.gz
starshatter-8e94244f86e657e4113e35438e59cf5771882b25.tar.bz2
libogg and libvorbis are no longer part of this source tree
Diffstat (limited to 'contrib/CMakeLists.txt')
-rw-r--r--contrib/CMakeLists.txt9
1 files changed, 3 insertions, 6 deletions
diff --git a/contrib/CMakeLists.txt b/contrib/CMakeLists.txt
index 138dc01..520ca73 100644
--- a/contrib/CMakeLists.txt
+++ b/contrib/CMakeLists.txt
@@ -2,15 +2,12 @@ include(ApplyPatch)
include(FetchContent)
include(MakeAvailable)
add_subdirectory(libpng)
-add_subdirectory(zlib)
-make_available(zlib libpng)
-add_library(Png::png ALIAS png15)
add_subdirectory(ogg)
+add_subdirectory(vorbis)
+add_subdirectory(zlib)
+make_available(libpng ogg vorbis zlib)
add_subdirectory(Opcode)
add_subdirectory(sha1)
-add_subdirectory(vorbis)
-get_target_property(LIBB_INCLUDES Png::png INCLUDE_DIRECTORIES)
-message(STATUS "PNG includes: ${LIBB_INCLUDES}")
install(
TARGETS png15 Opcode zlib
RUNTIME