summaryrefslogtreecommitdiffhomepage
path: root/contrib/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2024-03-03 02:21:46 +0100
committerAki <please@ignore.pl>2024-03-03 02:26:05 +0100
commitdad0e8562c8e5994fcf2ebedac5a7ec920297d1f (patch)
tree1bf6bc6aa5531594588a5ec248e976110365c301 /contrib/CMakeLists.txt
parentca18c5b1b5004ffa88b6b3b85cd038d1217c09c6 (diff)
downloadstarshatter-dad0e8562c8e5994fcf2ebedac5a7ec920297d1f.zip
starshatter-dad0e8562c8e5994fcf2ebedac5a7ec920297d1f.tar.gz
starshatter-dad0e8562c8e5994fcf2ebedac5a7ec920297d1f.tar.bz2
libpng sources removed from this tree
Diffstat (limited to 'contrib/CMakeLists.txt')
-rw-r--r--contrib/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/contrib/CMakeLists.txt b/contrib/CMakeLists.txt
index b8c25bf..138dc01 100644
--- a/contrib/CMakeLists.txt
+++ b/contrib/CMakeLists.txt
@@ -1,14 +1,16 @@
+include(ApplyPatch)
include(FetchContent)
include(MakeAvailable)
-add_subdirectory(zlib)
-make_available(zlib)
add_subdirectory(libpng)
+add_subdirectory(zlib)
+make_available(zlib libpng)
+add_library(Png::png ALIAS png15)
add_subdirectory(ogg)
add_subdirectory(Opcode)
add_subdirectory(sha1)
add_subdirectory(vorbis)
-get_target_property(LIBB_INCLUDES Zlib::zlib INCLUDE_DIRECTORIES)
-message(STATUS "Zlib includes: ${LIBB_INCLUDES}")
+get_target_property(LIBB_INCLUDES Png::png INCLUDE_DIRECTORIES)
+message(STATUS "PNG includes: ${LIBB_INCLUDES}")
install(
TARGETS png15 Opcode zlib
RUNTIME