summaryrefslogtreecommitdiffhomepage
path: root/StarsEx/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2022-04-01 21:42:56 +0200
committerAki <please@ignore.pl>2022-04-01 22:21:44 +0200
commit3f320f31fc4f9e90302bd62208a52bfd8d3fd7c2 (patch)
tree234fe74a29b15e37b8dbd40d1d58da9286c6b851 /StarsEx/CMakeLists.txt
parent3c487c5cd69c53d6fea948643c0a76df03516605 (diff)
downloadstarshatter-3f320f31fc4f9e90302bd62208a52bfd8d3fd7c2.zip
starshatter-3f320f31fc4f9e90302bd62208a52bfd8d3fd7c2.tar.gz
starshatter-3f320f31fc4f9e90302bd62208a52bfd8d3fd7c2.tar.bz2
Separated Main to own module
Intent is to separate headless server and game and make a dedicated executable for each. While this can be done without any directory changes, this is intended to cause as many compilation and linking errors as possible in order to clean them up and refactor general structure of the whole project.
Diffstat (limited to 'StarsEx/CMakeLists.txt')
-rw-r--r--StarsEx/CMakeLists.txt11
1 files changed, 2 insertions, 9 deletions
diff --git a/StarsEx/CMakeLists.txt b/StarsEx/CMakeLists.txt
index 6961ad4..b66eb85 100644
--- a/StarsEx/CMakeLists.txt
+++ b/StarsEx/CMakeLists.txt
@@ -1,8 +1,7 @@
project(StarsEx)
include(GitDescribe)
-include(GitToResource)
-add_executable(
- StarsEx WIN32
+add_library(
+ StarsEx STATIC
ActiveWindow.cpp
Archive.cpp
Asteroid.cpp
@@ -126,7 +125,6 @@ add_executable(
Locale_ss.cpp
MCIWave.cpp
MachineInfo.cpp
- Main.cpp
MapView.cpp
Menu.cpp
MenuDlg.cpp
@@ -301,15 +299,11 @@ target_compile_definitions(
PRIVATE _ALLOW_KEYWORD_MACROS
)
git_describe(VERSION)
-git_to_resource(RC_VERSION ${VERSION})
-configure_file(Stars.rc.conf ${CMAKE_CURRENT_BINARY_DIR}/Stars.rc @ONLY)
configure_file(VersionInfo.cpp.conf ${CMAKE_CURRENT_BINARY_DIR}/VersionInfo.cpp @ONLY)
target_sources(
StarsEx
- PUBLIC ${CMAKE_CURRENT_BINARY_DIR}/Stars.rc
PUBLIC ${CMAKE_CURRENT_BINARY_DIR}/VersionInfo.cpp
)
-set_target_properties(StarsEx PROPERTIES OUTPUT_NAME Starshatter)
if(MSVC)
target_include_directories(
StarsEx
@@ -345,4 +339,3 @@ else()
PUBLIC -l:libdxguid.a
)
endif()
-install(TARGETS StarsEx RUNTIME DESTINATION ${CMAKE_INSTALL_PREFIX})