summaryrefslogtreecommitdiff
path: root/sim/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2023-02-03 22:00:28 +0100
committerAki <please@ignore.pl>2023-02-03 22:00:28 +0100
commit9b453277059fd015703873172d0dc87b4a29cb55 (patch)
tree3df0415c5b8160f9d97dae12f0c7adb55c4a23db /sim/CMakeLists.txt
parentb5a71a9c776386805a12a722be23bf8d7b7e25fe (diff)
downloadkurator-9b453277059fd015703873172d0dc87b4a29cb55.zip
kurator-9b453277059fd015703873172d0dc87b4a29cb55.tar.gz
kurator-9b453277059fd015703873172d0dc87b4a29cb55.tar.bz2
Created engine module right now containing only Point
This might be a bit too generic of a name, but the intent is to get the main shared abstracts for gameplay loop and/or simulation outside of the game executable implementation to redirect dependencies.
Diffstat (limited to 'sim/CMakeLists.txt')
-rw-r--r--sim/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/sim/CMakeLists.txt b/sim/CMakeLists.txt
index 1cae7b0..ef80c77 100644
--- a/sim/CMakeLists.txt
+++ b/sim/CMakeLists.txt
@@ -6,7 +6,6 @@ add_library(
src/Builder.cpp
src/FloatingMovement.cpp
src/HitPoints.cpp
- src/Point.cpp
src/RandomSpawner.cpp
src/TeamManager.cpp
src/TurretControl.cpp
@@ -19,6 +18,7 @@ target_link_libraries(
${PROJECT_NAME}
PUBLIC EnTT::EnTT
PUBLIC campaign
+ PUBLIC engine
PRIVATE stats
PUBLIC universe
)