summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2022-04-18 23:50:31 +0200
committerAki <please@ignore.pl>2022-04-18 23:50:31 +0200
commit78097b5496209b56cef9d7fc8d6c13e4c87e0eb1 (patch)
tree29ccba95bafd04b594938a7f55be61c52bf4f4cc /CMakeLists.txt
parent5bb6b95fe71d33956491b98c29bf464a440ad221 (diff)
downloadbullethell2022-78097b5496209b56cef9d7fc8d6c13e4c87e0eb1.zip
bullethell2022-78097b5496209b56cef9d7fc8d6c13e4c87e0eb1.tar.gz
bullethell2022-78097b5496209b56cef9d7fc8d6c13e4c87e0eb1.tar.bz2
Added simple behaviours for enemies
I don't quite like FallingAndOscillating approach. Perhaps it will be better to just make it a list/vector in the enemy to allow for composition.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 11b364e..7d81491 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,12 +16,16 @@ add_executable(
ConstantVelocity.cpp
Enemy.cpp
ExampleGenerator.cpp
+ Falling.cpp
+ FallingAndOscillating.cpp
Game.cpp
GameScreen.cpp
Generator.cpp
KeyboardController.cpp
main.cpp
+ Oscillating.cpp
Player.cpp
+ Static.cpp
TestStage.cpp
TitleScreen.cpp
)