summaryrefslogtreecommitdiffhomepage
path: root/contrib/vorbis/examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/vorbis/examples/Makefile.am')
-rw-r--r--contrib/vorbis/examples/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/contrib/vorbis/examples/Makefile.am b/contrib/vorbis/examples/Makefile.am
new file mode 100644
index 0000000..5881635
--- /dev/null
+++ b/contrib/vorbis/examples/Makefile.am
@@ -0,0 +1,34 @@
+## Process this file with automake to produce Makefile.in
+
+AUTOMAKE_OPTIONS = foreign
+
+noinst_PROGRAMS = decoder_example encoder_example chaining_example\
+ vorbisfile_example seeking_example
+
+EXTRA_DIST = frameview.pl
+
+AM_CPPFLAGS = -I$(top_srcdir)/include @OGG_CFLAGS@
+
+# uncomment to build static executables from the example code
+#LDFLAGS = -all-static
+
+decoder_example_SOURCES = decoder_example.c
+decoder_example_LDADD = $(top_builddir)/lib/libvorbis.la @OGG_LIBS@
+
+encoder_example_SOURCES = encoder_example.c
+encoder_example_LDADD = $(top_builddir)/lib/libvorbisenc.la $(top_builddir)/lib/libvorbis.la @OGG_LIBS@
+
+chaining_example_SOURCES = chaining_example.c
+chaining_example_LDADD = $(top_builddir)/lib/libvorbisfile.la $(top_builddir)/lib/libvorbis.la @OGG_LIBS@
+
+vorbisfile_example_SOURCES = vorbisfile_example.c
+vorbisfile_example_LDADD = $(top_builddir)/lib/libvorbisfile.la $(top_builddir)/lib/libvorbis.la @OGG_LIBS@
+
+seeking_example_SOURCES = seeking_example.c
+seeking_example_LDADD = $(top_builddir)/lib/libvorbisfile.la $(top_builddir)/lib/libvorbis.la @OGG_LIBS@
+
+debug:
+ $(MAKE) all CFLAGS="@DEBUG@"
+
+profile:
+ $(MAKE) all CFLAGS="@PROFILE@"