summaryrefslogtreecommitdiffhomepage
path: root/contrib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/CMakeLists.txt')
-rw-r--r--contrib/CMakeLists.txt30
1 files changed, 0 insertions, 30 deletions
diff --git a/contrib/CMakeLists.txt b/contrib/CMakeLists.txt
deleted file mode 100644
index 2c9f2f1..0000000
--- a/contrib/CMakeLists.txt
+++ /dev/null
@@ -1,30 +0,0 @@
-include(ApplyPatch)
-include(FetchContent)
-include(MakeAvailable)
-add_subdirectory(gtest)
-add_subdirectory(infoware)
-add_subdirectory(libpng)
-add_subdirectory(ogg)
-add_subdirectory(vorbis)
-add_subdirectory(zlib)
-make_available(gtest infoware libpng ogg vorbis zlib)
-add_subdirectory(Opcode)
-add_subdirectory(sha1)
-install(
- TARGETS png15 Opcode
- RUNTIME
- COMPONENT Runtime
- DESTINATION ${CMAKE_INSTALL_PREFIX}
- )
-if(NOT MSVC)
- foreach(LIB IN ITEMS "libstdc++-6.dll" "libwinpthread-1.dll" "libgcc_s_dw2-1.dll")
- find_file(LIBRARY_${LIB} ${LIB} PATHS ${CMAKE_FIND_ROOT_PATH}/bin)
- if(LIBRARY_${LIB})
- install(
- PROGRAMS ${LIBRARY_${LIB}}
- COMPONENT Runtime
- DESTINATION ${CMAKE_INSTALL_PREFIX}
- )
- endif()
- endforeach()
-endif()