summaryrefslogtreecommitdiffhomepage
path: root/Starshatter/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Starshatter/CMakeLists.txt')
-rw-r--r--Starshatter/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/Starshatter/CMakeLists.txt b/Starshatter/CMakeLists.txt
index 913685f..e73a639 100644
--- a/Starshatter/CMakeLists.txt
+++ b/Starshatter/CMakeLists.txt
@@ -1,5 +1,4 @@
project(Starshatter)
-include(GitToResource)
add_executable(
Starshatter WIN32
Main.cpp
@@ -12,8 +11,7 @@ target_link_libraries(
Starshatter
PRIVATE StarsEx
)
-git_to_resource(RC_VERSION ${STARSHATTER_VERSION})
-configure_file(Starshatter.rc.conf ${CMAKE_CURRENT_BINARY_DIR}/Starshatter.rc @ONLY)
+add_version_file(Starshatter.rc Starshatter.rc.conf)
target_sources(
Starshatter
PUBLIC ${CMAKE_CURRENT_BINARY_DIR}/Starshatter.rc