summaryrefslogtreecommitdiffhomepage
path: root/Starshatter/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Starshatter/CMakeLists.txt')
-rw-r--r--Starshatter/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/Starshatter/CMakeLists.txt b/Starshatter/CMakeLists.txt
new file mode 100644
index 0000000..9623f9a
--- /dev/null
+++ b/Starshatter/CMakeLists.txt
@@ -0,0 +1,23 @@
+project(Starshatter)
+include(GitDescribe)
+include(GitToResource)
+add_executable(
+ Starshatter WIN32
+ Main.cpp
+ )
+target_include_directories(
+ Starshatter
+ PRIVATE ${CMAKE_CURRENT_SOURCE_DIR}
+ )
+target_link_libraries(
+ Starshatter
+ PRIVATE StarsEx
+ )
+git_describe(VERSION)
+git_to_resource(RC_VERSION ${VERSION})
+configure_file(Starshatter.rc.conf ${CMAKE_CURRENT_BINARY_DIR}/Starshatter.rc @ONLY)
+target_sources(
+ Starshatter
+ PUBLIC ${CMAKE_CURRENT_BINARY_DIR}/Starshatter.rc
+ )
+install(TARGETS Starshatter RUNTIME DESTINATION ${CMAKE_INSTALL_PREFIX})