summaryrefslogtreecommitdiffhomepage
path: root/Starshatter/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Starshatter/CMakeLists.txt')
-rw-r--r--Starshatter/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/Starshatter/CMakeLists.txt b/Starshatter/CMakeLists.txt
index 9623f9a..2501825 100644
--- a/Starshatter/CMakeLists.txt
+++ b/Starshatter/CMakeLists.txt
@@ -1,5 +1,4 @@
project(Starshatter)
-include(GitDescribe)
include(GitToResource)
add_executable(
Starshatter WIN32
@@ -13,8 +12,7 @@ target_link_libraries(
Starshatter
PRIVATE StarsEx
)
-git_describe(VERSION)
-git_to_resource(RC_VERSION ${VERSION})
+git_to_resource(RC_VERSION ${STARSHATTER_VERSION})
configure_file(Starshatter.rc.conf ${CMAKE_CURRENT_BINARY_DIR}/Starshatter.rc @ONLY)
target_sources(
Starshatter