summaryrefslogtreecommitdiffhomepage
path: root/StarsEx/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'StarsEx/CMakeLists.txt')
-rw-r--r--StarsEx/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/StarsEx/CMakeLists.txt b/StarsEx/CMakeLists.txt
index 5083039..1c443b1 100644
--- a/StarsEx/CMakeLists.txt
+++ b/StarsEx/CMakeLists.txt
@@ -290,7 +290,7 @@ target_compile_definitions(
StarsEx
PRIVATE _ALLOW_KEYWORD_MACROS
)
-configure_file(VersionInfo.cpp.conf ${CMAKE_CURRENT_BINARY_DIR}/VersionInfo.cpp @ONLY)
+add_version_file(VersionInfo.cpp VersionInfo.cpp.conf)
target_sources(
StarsEx
PRIVATE ${CMAKE_CURRENT_BINARY_DIR}/VersionInfo.cpp