summaryrefslogtreecommitdiffhomepage
path: root/Opcode/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Opcode/CMakeLists.txt')
-rw-r--r--Opcode/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/Opcode/CMakeLists.txt b/Opcode/CMakeLists.txt
index e60d33c..6010c50 100644
--- a/Opcode/CMakeLists.txt
+++ b/Opcode/CMakeLists.txt
@@ -42,13 +42,14 @@ add_library(
)
target_include_directories(
Opcode
- PRIVATE .
+ PUBLIC ${CMAKE_CURRENT_SOURCE_DIR}
)
target_precompile_headers(
Opcode
- PRIVATE StdAfx.h
+ PUBLIC StdAfx.h
)
target_compile_definitions(
Opcode
- PUBLIC OPCODE_EXPORTS
+ PRIVATE OPCODE_EXPORTS
+ PUBLIC _ALLOW_KEYWORD_MACROS
)