summaryrefslogtreecommitdiffhomepage
path: root/NetEx/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'NetEx/CMakeLists.txt')
-rw-r--r--NetEx/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/NetEx/CMakeLists.txt b/NetEx/CMakeLists.txt
new file mode 100644
index 0000000..ccb0f01
--- /dev/null
+++ b/NetEx/CMakeLists.txt
@@ -0,0 +1,29 @@
+project(NetEx)
+add_library(
+ NetEx
+ STATIC
+ HttpClient.cpp
+ HttpServer.cpp
+ HttpServlet.cpp
+ HttpServletExec.cpp
+ NetAddr.cpp
+ NetClient.cpp
+ NetGram.cpp
+ NetHost.cpp
+ NetLayer.cpp
+ NetLink.cpp
+ NetMsg.cpp
+ NetPeer.cpp
+ NetServer.cpp
+ NetSock.cpp
+ )
+set(WINDOWSSDK_PATH "C:/Program Files (x86)/Windows Kits/10/Include/10.0.19041.0/um")
+target_include_directories(
+ NetEx
+ PUBLIC ${CMAKE_CURRENT_SOURCE_DIR}
+ PUBLIC ${WINDOWSSDK_PATH} # FIXME
+ )
+target_link_libraries(
+ NetEx
+ PUBLIC FoundationEx
+ )