summaryrefslogtreecommitdiffhomepage
path: root/FoundationEx/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'FoundationEx/CMakeLists.txt')
-rw-r--r--FoundationEx/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/FoundationEx/CMakeLists.txt b/FoundationEx/CMakeLists.txt
index 972a242..d7d6ffa 100644
--- a/FoundationEx/CMakeLists.txt
+++ b/FoundationEx/CMakeLists.txt
@@ -1,7 +1,7 @@
project(FoundationEx)
+
add_library(
${PROJECT_NAME} STATIC
- src/Reader_.cpp
src/Text.cpp
src/Utils.cpp
src/reader.cpp
@@ -9,6 +9,7 @@ add_library(
src/reader/file.cpp
)
target_include_directories(${PROJECT_NAME} PUBLIC include)
+
add_executable(${PROJECT_NAME}_test test/Text.cpp test/reader.cpp test/data.cpp)
target_link_libraries(${PROJECT_NAME}_test PRIVATE ${PROJECT_NAME} GTest::gtest_main)
generate_emulator(${PROJECT_NAME}_test)