summaryrefslogtreecommitdiffhomepage
path: root/vorbis/test/Makefile.am
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2021-10-01 23:46:47 +0200
committerAki <please@ignore.pl>2021-10-01 23:46:47 +0200
commitddd76aa4e1571c8d5965709db5c3cd47a89c9a38 (patch)
tree4e07bfaebede6531a70984fdebc855bca52f394a /vorbis/test/Makefile.am
parent3a507e08b1d4e5970b27401a7e6517570d529400 (diff)
parentc2d2c3551501110fddd78674d5435bfaa70382a3 (diff)
downloadstarshatter-ddd76aa4e1571c8d5965709db5c3cd47a89c9a38.zip
starshatter-ddd76aa4e1571c8d5965709db5c3cd47a89c9a38.tar.gz
starshatter-ddd76aa4e1571c8d5965709db5c3cd47a89c9a38.tar.bz2
Project is now built with CMake
Diffstat (limited to 'vorbis/test/Makefile.am')
-rw-r--r--vorbis/test/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/vorbis/test/Makefile.am b/vorbis/test/Makefile.am
new file mode 100644
index 0000000..b68ebdb
--- /dev/null
+++ b/vorbis/test/Makefile.am
@@ -0,0 +1,19 @@
+## Process this file with automake to produce Makefile.in
+
+AUTOMAKE_OPTIONS = foreign
+
+check_PROGRAMS = test
+
+check: $(check_PROGRAMS)
+ ./test$(EXEEXT)
+
+AM_CPPFLAGS = -I$(top_srcdir)/include @OGG_CFLAGS@
+
+test_SOURCES = util.c util.h write_read.c write_read.h test.c
+test_LDADD = ../lib/libvorbisenc.la ../lib/libvorbis.la @OGG_LIBS@ @VORBIS_LIBS@
+
+debug:
+ $(MAKE) check CFLAGS="@DEBUG@"
+
+profile:
+ $(MAKE) check CFLAGS="@PROFILE@"