summaryrefslogtreecommitdiffhomepage
path: root/vorbis/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2022-02-09 22:15:14 +0100
committerAki <please@ignore.pl>2022-02-09 22:16:06 +0100
commit2d7dd844219965b81e81848e60d7f7bf23035ee4 (patch)
tree1b6d1e0961ae5d20e40f27b08a73f41e1dedaee4 /vorbis/lib/CMakeLists.txt
parent3f07a2c060c5c6d53ca6c066f50ec91bcf04b52d (diff)
downloadstarshatter-2d7dd844219965b81e81848e60d7f7bf23035ee4.zip
starshatter-2d7dd844219965b81e81848e60d7f7bf23035ee4.tar.gz
starshatter-2d7dd844219965b81e81848e60d7f7bf23035ee4.tar.bz2
Removed install-time rules from third-party libraries
Removing and starting anew is one way. The other way would be to move the third-party libraries out of the tree and just install them properly, but I'm unsure how well it will go for Windows hosts, so I'm choosing the self-contained route.
Diffstat (limited to 'vorbis/lib/CMakeLists.txt')
-rw-r--r--vorbis/lib/CMakeLists.txt6
1 files changed, 0 insertions, 6 deletions
diff --git a/vorbis/lib/CMakeLists.txt b/vorbis/lib/CMakeLists.txt
index daa3416..f0993f2 100644
--- a/vorbis/lib/CMakeLists.txt
+++ b/vorbis/lib/CMakeLists.txt
@@ -93,12 +93,6 @@ if (NOT BUILD_FRAMEWORK)
add_library(Vorbis::vorbis ALIAS vorbis)
add_library(Vorbis::vorbisenc ALIAS vorbisenc)
add_library(Vorbis::vorbisfile ALIAS vorbisfile)
-
- install(FILES ${VORBIS_PUBLIC_HEADERS} DESTINATION ${CMAKE_INSTALL_FULL_INCLUDEDIR}/vorbis)
-
- install(TARGETS vorbis RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR} LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR} ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR} FRAMEWORK DESTINATION ${CMAKE_INSTALL_LIBDIR})
- install(TARGETS vorbisenc RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR} LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR} ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR} FRAMEWORK DESTINATION ${CMAKE_INSTALL_LIBDIR})
- install(TARGETS vorbisfile RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR} LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR} ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR} FRAMEWORK DESTINATION ${CMAKE_INSTALL_LIBDIR})
else()
add_library(vorbis ${VORBIS_PUBLIC_HEADERS} ${VORBIS_HEADERS} ${VORBIS_SOURCES} ${VORBISFILE_SOURCES} ${VORBISENC_SOURCES})
set_target_properties(vorbis PROPERTIES