summaryrefslogtreecommitdiffhomepage
path: root/vorbis/examples/Makefile.am
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2021-10-01 23:46:47 +0200
committerAki <please@ignore.pl>2021-10-01 23:46:47 +0200
commitddd76aa4e1571c8d5965709db5c3cd47a89c9a38 (patch)
tree4e07bfaebede6531a70984fdebc855bca52f394a /vorbis/examples/Makefile.am
parent3a507e08b1d4e5970b27401a7e6517570d529400 (diff)
parentc2d2c3551501110fddd78674d5435bfaa70382a3 (diff)
downloadstarshatter-ddd76aa4e1571c8d5965709db5c3cd47a89c9a38.zip
starshatter-ddd76aa4e1571c8d5965709db5c3cd47a89c9a38.tar.gz
starshatter-ddd76aa4e1571c8d5965709db5c3cd47a89c9a38.tar.bz2
Project is now built with CMake
Diffstat (limited to 'vorbis/examples/Makefile.am')
-rw-r--r--vorbis/examples/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/vorbis/examples/Makefile.am b/vorbis/examples/Makefile.am
new file mode 100644
index 0000000..5881635
--- /dev/null
+++ b/vorbis/examples/Makefile.am
@@ -0,0 +1,34 @@
+## Process this file with automake to produce Makefile.in
+
+AUTOMAKE_OPTIONS = foreign
+
+noinst_PROGRAMS = decoder_example encoder_example chaining_example\
+ vorbisfile_example seeking_example
+
+EXTRA_DIST = frameview.pl
+
+AM_CPPFLAGS = -I$(top_srcdir)/include @OGG_CFLAGS@
+
+# uncomment to build static executables from the example code
+#LDFLAGS = -all-static
+
+decoder_example_SOURCES = decoder_example.c
+decoder_example_LDADD = $(top_builddir)/lib/libvorbis.la @OGG_LIBS@
+
+encoder_example_SOURCES = encoder_example.c
+encoder_example_LDADD = $(top_builddir)/lib/libvorbisenc.la $(top_builddir)/lib/libvorbis.la @OGG_LIBS@
+
+chaining_example_SOURCES = chaining_example.c
+chaining_example_LDADD = $(top_builddir)/lib/libvorbisfile.la $(top_builddir)/lib/libvorbis.la @OGG_LIBS@
+
+vorbisfile_example_SOURCES = vorbisfile_example.c
+vorbisfile_example_LDADD = $(top_builddir)/lib/libvorbisfile.la $(top_builddir)/lib/libvorbis.la @OGG_LIBS@
+
+seeking_example_SOURCES = seeking_example.c
+seeking_example_LDADD = $(top_builddir)/lib/libvorbisfile.la $(top_builddir)/lib/libvorbis.la @OGG_LIBS@
+
+debug:
+ $(MAKE) all CFLAGS="@DEBUG@"
+
+profile:
+ $(MAKE) all CFLAGS="@PROFILE@"