summaryrefslogtreecommitdiffhomepage
path: root/vorbis/Makefile.am
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2021-10-01 23:46:47 +0200
committerAki <please@ignore.pl>2021-10-01 23:46:47 +0200
commitddd76aa4e1571c8d5965709db5c3cd47a89c9a38 (patch)
tree4e07bfaebede6531a70984fdebc855bca52f394a /vorbis/Makefile.am
parent3a507e08b1d4e5970b27401a7e6517570d529400 (diff)
parentc2d2c3551501110fddd78674d5435bfaa70382a3 (diff)
downloadstarshatter-ddd76aa4e1571c8d5965709db5c3cd47a89c9a38.zip
starshatter-ddd76aa4e1571c8d5965709db5c3cd47a89c9a38.tar.gz
starshatter-ddd76aa4e1571c8d5965709db5c3cd47a89c9a38.tar.bz2
Project is now built with CMake
Diffstat (limited to 'vorbis/Makefile.am')
-rw-r--r--vorbis/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/vorbis/Makefile.am b/vorbis/Makefile.am
new file mode 100644
index 0000000..c35131a
--- /dev/null
+++ b/vorbis/Makefile.am
@@ -0,0 +1,47 @@
+## Process this file with automake to produce Makefile.in
+
+AUTOMAKE_OPTIONS = foreign 1.11 dist-zip dist-xz
+
+ACLOCAL_AMFLAGS = -I m4
+
+SUBDIRS = m4 include vq lib test doc
+
+if BUILD_EXAMPLES
+SUBDIRS += examples
+endif
+
+m4datadir = $(datadir)/aclocal
+m4data_DATA = vorbis.m4
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = vorbis.pc vorbisenc.pc vorbisfile.pc
+
+EXTRA_DIST = \
+ CHANGES COPYING \
+ autogen.sh \
+ libvorbis.spec libvorbis.spec.in \
+ vorbis.m4 \
+ vorbis.pc.in vorbisenc.pc.in vorbisfile.pc.in \
+ vorbis-uninstalled.pc.in \
+ vorbisenc-uninstalled.pc.in \
+ vorbisfile-uninstalled.pc.in \
+ symbian \
+ macosx win32
+
+
+DISTCHECK_CONFIGURE_FLAGS = --enable-docs
+
+dist-hook:
+ for item in $(EXTRA_DIST); do \
+ if test -d $$item; then \
+ echo -n "cleaning $$item dir for distribution..."; \
+ rm -rf `find $(distdir)/$$item -name .svn`; \
+ echo "OK"; \
+ fi; \
+ done
+
+debug:
+ $(MAKE) all CFLAGS="@DEBUG@"
+
+profile:
+ $(MAKE) all CFLAGS="@PROFILE@"