summaryrefslogtreecommitdiffhomepage
path: root/vorbis/Makefile.am
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2021-09-29 22:52:49 +0200
committerAki <please@ignore.pl>2021-09-29 22:52:49 +0200
commit760f65d35df281b04d99843958623d99ab35dcaf (patch)
tree76f6f05695822256bbf8097fa0aa6b5d2a34369b /vorbis/Makefile.am
parentbdb934044a10bcccdea4ae5e9b067a2e764e0e7f (diff)
parent74f4b1bc3b627ba4c7e03498234d88cacdfbe97b (diff)
downloadstarshatter-760f65d35df281b04d99843958623d99ab35dcaf.zip
starshatter-760f65d35df281b04d99843958623d99ab35dcaf.tar.gz
starshatter-760f65d35df281b04d99843958623d99ab35dcaf.tar.bz2
Merge commit '74f4b1bc3b627ba4c7e03498234d88cacdfbe97b' as 'vorbis'
Diffstat (limited to 'vorbis/Makefile.am')
-rw-r--r--vorbis/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/vorbis/Makefile.am b/vorbis/Makefile.am
new file mode 100644
index 0000000..c35131a
--- /dev/null
+++ b/vorbis/Makefile.am
@@ -0,0 +1,47 @@
+## Process this file with automake to produce Makefile.in
+
+AUTOMAKE_OPTIONS = foreign 1.11 dist-zip dist-xz
+
+ACLOCAL_AMFLAGS = -I m4
+
+SUBDIRS = m4 include vq lib test doc
+
+if BUILD_EXAMPLES
+SUBDIRS += examples
+endif
+
+m4datadir = $(datadir)/aclocal
+m4data_DATA = vorbis.m4
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = vorbis.pc vorbisenc.pc vorbisfile.pc
+
+EXTRA_DIST = \
+ CHANGES COPYING \
+ autogen.sh \
+ libvorbis.spec libvorbis.spec.in \
+ vorbis.m4 \
+ vorbis.pc.in vorbisenc.pc.in vorbisfile.pc.in \
+ vorbis-uninstalled.pc.in \
+ vorbisenc-uninstalled.pc.in \
+ vorbisfile-uninstalled.pc.in \
+ symbian \
+ macosx win32
+
+
+DISTCHECK_CONFIGURE_FLAGS = --enable-docs
+
+dist-hook:
+ for item in $(EXTRA_DIST); do \
+ if test -d $$item; then \
+ echo -n "cleaning $$item dir for distribution..."; \
+ rm -rf `find $(distdir)/$$item -name .svn`; \
+ echo "OK"; \
+ fi; \
+ done
+
+debug:
+ $(MAKE) all CFLAGS="@DEBUG@"
+
+profile:
+ $(MAKE) all CFLAGS="@PROFILE@"