summaryrefslogtreecommitdiffhomepage
path: root/vorbis/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2021-09-29 22:54:02 +0200
committerAki <please@ignore.pl>2021-09-29 22:54:02 +0200
commit9c1cdebcffa2fb9797d664e6d9cd6c110fe57db6 (patch)
treeaf1b62fccb4693614077eec8f6c524c2ee1825a4 /vorbis/CMakeLists.txt
parent760f65d35df281b04d99843958623d99ab35dcaf (diff)
downloadstarshatter-9c1cdebcffa2fb9797d664e6d9cd6c110fe57db6.zip
starshatter-9c1cdebcffa2fb9797d664e6d9cd6c110fe57db6.tar.gz
starshatter-9c1cdebcffa2fb9797d664e6d9cd6c110fe57db6.tar.bz2
Integrated ogg and vorbis into cmake root
Diffstat (limited to 'vorbis/CMakeLists.txt')
-rw-r--r--vorbis/CMakeLists.txt13
1 files changed, 0 insertions, 13 deletions
diff --git a/vorbis/CMakeLists.txt b/vorbis/CMakeLists.txt
index bbc045b..61c1c1b 100644
--- a/vorbis/CMakeLists.txt
+++ b/vorbis/CMakeLists.txt
@@ -52,19 +52,6 @@ endfunction()
message(STATUS "Configuring ${PROJECT_NAME} ${PROJECT_VERSION}")
-# Find ogg dependency
-if(NOT OGG_ROOT)
- find_package(PkgConfig QUIET)
- pkg_check_modules(PC_OGG QUIET ogg)
- find_path(OGG_INCLUDE_DIRS NAMES ogg/ogg.h HINTS ${PC_OGG_INCLUDE_DIRS} PATH_SUFFIXES ogg)
- find_library(OGG_LIBRARIES NAMES ogg HINTS ${PC_OGG_LIBRARY_DIRS})
-else()
- find_path(OGG_INCLUDE_DIRS NAMES ogg/ogg.h HINTS ${OGG_ROOT}/include PATH_SUFFIXES ogg)
- find_library(OGG_LIBRARIES NAMES ogg HINTS ${OGG_ROOT}/lib ${OGG_ROOT}/lib64)
-endif()
-include(FindPackageHandleStandardArgs)
-find_package_handle_standard_args(OGG DEFAULT_MSG OGG_INCLUDE_DIRS OGG_LIBRARIES)
-
add_subdirectory(lib)
configure_pkg_config_file(vorbis.pc.in)