summaryrefslogtreecommitdiffhomepage
path: root/third-party/sha1/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2024-03-12 22:07:03 +0100
committerAki <please@ignore.pl>2024-03-12 22:07:36 +0100
commit81bb6873f1c0291fecbf6e429ad15ac3db66a4c0 (patch)
treefd7552ecabeeffb45a1fbe3730ab62bc7a64dd85 /third-party/sha1/CMakeLists.txt
parentf43d32d6d2cc7ecd04f4f06f20d5a6fc2c87c9ae (diff)
downloadstarshatter-81bb6873f1c0291fecbf6e429ad15ac3db66a4c0.zip
starshatter-81bb6873f1c0291fecbf6e429ad15ac3db66a4c0.tar.gz
starshatter-81bb6873f1c0291fecbf6e429ad15ac3db66a4c0.tar.bz2
Legal notices updated
Rename contrib -> third-party intendes to express the origin and purpose of that part of the code better. I plan to readd contrib/ again but with more in-project things like bash-completions, dev workflow scripts etc.
Diffstat (limited to 'third-party/sha1/CMakeLists.txt')
-rw-r--r--third-party/sha1/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/third-party/sha1/CMakeLists.txt b/third-party/sha1/CMakeLists.txt
new file mode 100644
index 0000000..cc6fab2
--- /dev/null
+++ b/third-party/sha1/CMakeLists.txt
@@ -0,0 +1,6 @@
+cmake_minimum_required(VERSION 3.20)
+project(Sha1)
+add_library(${PROJECT_NAME} STATIC Sha1.cpp)
+target_include_directories(
+ ${PROJECT_NAME}
+ PUBLIC include)