summaryrefslogtreecommitdiffhomepage
path: root/third-party/libpng/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2024-03-12 22:07:03 +0100
committerAki <please@ignore.pl>2024-03-12 22:07:36 +0100
commit81bb6873f1c0291fecbf6e429ad15ac3db66a4c0 (patch)
treefd7552ecabeeffb45a1fbe3730ab62bc7a64dd85 /third-party/libpng/CMakeLists.txt
parentf43d32d6d2cc7ecd04f4f06f20d5a6fc2c87c9ae (diff)
downloadstarshatter-81bb6873f1c0291fecbf6e429ad15ac3db66a4c0.zip
starshatter-81bb6873f1c0291fecbf6e429ad15ac3db66a4c0.tar.gz
starshatter-81bb6873f1c0291fecbf6e429ad15ac3db66a4c0.tar.bz2
Legal notices updated
Rename contrib -> third-party intendes to express the origin and purpose of that part of the code better. I plan to readd contrib/ again but with more in-project things like bash-completions, dev workflow scripts etc.
Diffstat (limited to 'third-party/libpng/CMakeLists.txt')
-rw-r--r--third-party/libpng/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/third-party/libpng/CMakeLists.txt b/third-party/libpng/CMakeLists.txt
new file mode 100644
index 0000000..c8aafb6
--- /dev/null
+++ b/third-party/libpng/CMakeLists.txt
@@ -0,0 +1,11 @@
+FetchContent_Declare(
+ libpng
+ URL
+ https://download.sourceforge.net/libpng/libpng-1.5.1.tar.gz
+ https://ftp.ignore.pl/starshatter/resources/mirror/libpng-1.5.1.tar.gz
+ URL_HASH SHA1=29afc7422d4d8af1066f8783ae148e298520d5ba
+ PATCH_COMMAND ${CMAKE_COMMAND} -D "PATCH_FILE=${CMAKE_CURRENT_SOURCE_DIR}/1.zlib.patch" -P ${PATCH_SCRIPT}
+ PATCH_COMMAND ${CMAKE_COMMAND} -D "PATCH_FILE=${CMAKE_CURRENT_SOURCE_DIR}/2.export.patch" -P ${PATCH_SCRIPT}
+ PATCH_COMMAND ${CMAKE_COMMAND} -D "PATCH_FILE=${CMAKE_CURRENT_SOURCE_DIR}/3.includes.patch" -P ${PATCH_SCRIPT}
+ PATCH_COMMAND ${CMAKE_COMMAND} -D "PATCH_FILE=${CMAKE_CURRENT_SOURCE_DIR}/4.aliases.patch" -P ${PATCH_SCRIPT}
+ DOWNLOAD_EXTRACT_TIMESTAMP No)