summaryrefslogtreecommitdiffhomepage
path: root/ogg/src/Makefile.am
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2021-10-01 23:46:47 +0200
committerAki <please@ignore.pl>2021-10-01 23:46:47 +0200
commitddd76aa4e1571c8d5965709db5c3cd47a89c9a38 (patch)
tree4e07bfaebede6531a70984fdebc855bca52f394a /ogg/src/Makefile.am
parent3a507e08b1d4e5970b27401a7e6517570d529400 (diff)
parentc2d2c3551501110fddd78674d5435bfaa70382a3 (diff)
downloadstarshatter-ddd76aa4e1571c8d5965709db5c3cd47a89c9a38.zip
starshatter-ddd76aa4e1571c8d5965709db5c3cd47a89c9a38.tar.gz
starshatter-ddd76aa4e1571c8d5965709db5c3cd47a89c9a38.tar.bz2
Project is now built with CMake
Diffstat (limited to 'ogg/src/Makefile.am')
-rw-r--r--ogg/src/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/ogg/src/Makefile.am b/ogg/src/Makefile.am
new file mode 100644
index 0000000..9472626
--- /dev/null
+++ b/ogg/src/Makefile.am
@@ -0,0 +1,28 @@
+## Process this file with automake to produce Makefile.in
+
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include
+
+lib_LTLIBRARIES = libogg.la
+
+libogg_la_SOURCES = framing.c bitwise.c
+libogg_la_LDFLAGS = -no-undefined -version-info @LIB_CURRENT@:@LIB_REVISION@:@LIB_AGE@
+
+# build and run the self tests on 'make check'
+
+noinst_PROGRAMS = test_bitwise test_framing
+
+test_bitwise_SOURCES = bitwise.c
+test_bitwise_CFLAGS = -D_V_SELFTEST
+
+test_framing_SOURCES = framing.c
+test_framing_CFLAGS = -D_V_SELFTEST
+
+check: $(noinst_PROGRAMS)
+ ./test_bitwise$(EXEEXT)
+ ./test_framing$(EXEEXT)
+
+debug:
+ $(MAKE) all CFLAGS="@DEBUG@"
+
+profile:
+ $(MAKE) all CFLAGS="@PROFILE@"