summaryrefslogtreecommitdiffhomepage
path: root/ogg/src/Makefile.am
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2021-09-29 22:52:15 +0200
committerAki <please@ignore.pl>2021-09-29 22:52:15 +0200
commitbdb934044a10bcccdea4ae5e9b067a2e764e0e7f (patch)
treee8a5da9a4920cbb0743b418b7f5bc5466af3ca4e /ogg/src/Makefile.am
parent252409240827e63b47c492d12718c4514c72ae02 (diff)
parent8f3471999e929bb99116fac52b94d572c42ba15e (diff)
downloadstarshatter-bdb934044a10bcccdea4ae5e9b067a2e764e0e7f.zip
starshatter-bdb934044a10bcccdea4ae5e9b067a2e764e0e7f.tar.gz
starshatter-bdb934044a10bcccdea4ae5e9b067a2e764e0e7f.tar.bz2
Merge commit '8f3471999e929bb99116fac52b94d572c42ba15e' as 'ogg'
Diffstat (limited to 'ogg/src/Makefile.am')
-rw-r--r--ogg/src/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/ogg/src/Makefile.am b/ogg/src/Makefile.am
new file mode 100644
index 0000000..9472626
--- /dev/null
+++ b/ogg/src/Makefile.am
@@ -0,0 +1,28 @@
+## Process this file with automake to produce Makefile.in
+
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include
+
+lib_LTLIBRARIES = libogg.la
+
+libogg_la_SOURCES = framing.c bitwise.c
+libogg_la_LDFLAGS = -no-undefined -version-info @LIB_CURRENT@:@LIB_REVISION@:@LIB_AGE@
+
+# build and run the self tests on 'make check'
+
+noinst_PROGRAMS = test_bitwise test_framing
+
+test_bitwise_SOURCES = bitwise.c
+test_bitwise_CFLAGS = -D_V_SELFTEST
+
+test_framing_SOURCES = framing.c
+test_framing_CFLAGS = -D_V_SELFTEST
+
+check: $(noinst_PROGRAMS)
+ ./test_bitwise$(EXEEXT)
+ ./test_framing$(EXEEXT)
+
+debug:
+ $(MAKE) all CFLAGS="@DEBUG@"
+
+profile:
+ $(MAKE) all CFLAGS="@PROFILE@"