summaryrefslogtreecommitdiffhomepage
path: root/ogg/Makefile.am
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2021-09-29 22:52:15 +0200
committerAki <please@ignore.pl>2021-09-29 22:52:15 +0200
commitbdb934044a10bcccdea4ae5e9b067a2e764e0e7f (patch)
treee8a5da9a4920cbb0743b418b7f5bc5466af3ca4e /ogg/Makefile.am
parent252409240827e63b47c492d12718c4514c72ae02 (diff)
parent8f3471999e929bb99116fac52b94d572c42ba15e (diff)
downloadstarshatter-bdb934044a10bcccdea4ae5e9b067a2e764e0e7f.zip
starshatter-bdb934044a10bcccdea4ae5e9b067a2e764e0e7f.tar.gz
starshatter-bdb934044a10bcccdea4ae5e9b067a2e764e0e7f.tar.bz2
Merge commit '8f3471999e929bb99116fac52b94d572c42ba15e' as 'ogg'
Diffstat (limited to 'ogg/Makefile.am')
-rw-r--r--ogg/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/ogg/Makefile.am b/ogg/Makefile.am
new file mode 100644
index 0000000..8bfe303
--- /dev/null
+++ b/ogg/Makefile.am
@@ -0,0 +1,32 @@
+## Process this file with automake to produce Makefile.in
+
+
+#AUTOMAKE_OPTIONS = foreign 1.6 dist-zip
+AUTOMAKE_OPTIONS = foreign 1.11 dist-zip dist-xz
+
+SUBDIRS = src include doc
+
+m4datadir = $(datadir)/aclocal
+m4data_DATA = ogg.m4
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = ogg.pc
+
+EXTRA_DIST = README.md AUTHORS CHANGES COPYING \
+ libogg.spec libogg.spec.in \
+ ogg.m4 ogg.pc.in ogg-uninstalled.pc.in \
+ macosx win32
+
+dist-hook:
+ for item in $(EXTRA_DIST); do \
+ if test -d $$item; then \
+ echo -n "cleaning dir $$item for distribution..."; \
+ rm -rf `find $(distdir)/$$item -name .svn`; \
+ echo "OK"; \
+ fi; \
+ done
+debug:
+ $(MAKE) all CFLAGS="@DEBUG@"
+
+profile:
+ $(MAKE) all CFLAGS="@PROFILE@"