summaryrefslogtreecommitdiffhomepage
path: root/ogg/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2022-02-09 22:15:14 +0100
committerAki <please@ignore.pl>2022-02-09 22:16:06 +0100
commit2d7dd844219965b81e81848e60d7f7bf23035ee4 (patch)
tree1b6d1e0961ae5d20e40f27b08a73f41e1dedaee4 /ogg/CMakeLists.txt
parent3f07a2c060c5c6d53ca6c066f50ec91bcf04b52d (diff)
downloadstarshatter-2d7dd844219965b81e81848e60d7f7bf23035ee4.zip
starshatter-2d7dd844219965b81e81848e60d7f7bf23035ee4.tar.gz
starshatter-2d7dd844219965b81e81848e60d7f7bf23035ee4.tar.bz2
Removed install-time rules from third-party libraries
Removing and starting anew is one way. The other way would be to move the third-party libraries out of the tree and just install them properly, but I'm unsure how well it will go for Windows hosts, so I'm choosing the self-contained route.
Diffstat (limited to 'ogg/CMakeLists.txt')
-rw-r--r--ogg/CMakeLists.txt11
1 files changed, 0 insertions, 11 deletions
diff --git a/ogg/CMakeLists.txt b/ogg/CMakeLists.txt
index 6c25659..24f204f 100644
--- a/ogg/CMakeLists.txt
+++ b/ogg/CMakeLists.txt
@@ -105,14 +105,3 @@ if(BUILD_FRAMEWORK)
endif()
configure_pkg_config_file(ogg.pc.in)
-
-install(TARGETS ogg
- RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
- ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
- FRAMEWORK DESTINATION ${CMAKE_INSTALL_PREFIX}
- PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/ogg
-)
-install(FILES ${CMAKE_CURRENT_BINARY_DIR}/ogg.pc
- DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig
-)