summaryrefslogtreecommitdiffhomepage
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2021-09-29 22:52:49 +0200
committerAki <please@ignore.pl>2021-09-29 22:52:49 +0200
commit74f4b1bc3b627ba4c7e03498234d88cacdfbe97b (patch)
tree197b5978d6e38f44069ea92583098a1da04aa635 /examples/Makefile.am
downloadstarshatter-74f4b1bc3b627ba4c7e03498234d88cacdfbe97b.zip
starshatter-74f4b1bc3b627ba4c7e03498234d88cacdfbe97b.tar.gz
starshatter-74f4b1bc3b627ba4c7e03498234d88cacdfbe97b.tar.bz2
Squashed 'vorbis/' content from commit d22c3ab5f
git-subtree-dir: vorbis git-subtree-split: d22c3ab5f633460abc2532feee60ca0892134cbf
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
new file mode 100644
index 0000000..5881635
--- /dev/null
+++ b/examples/Makefile.am
@@ -0,0 +1,34 @@
+## Process this file with automake to produce Makefile.in
+
+AUTOMAKE_OPTIONS = foreign
+
+noinst_PROGRAMS = decoder_example encoder_example chaining_example\
+ vorbisfile_example seeking_example
+
+EXTRA_DIST = frameview.pl
+
+AM_CPPFLAGS = -I$(top_srcdir)/include @OGG_CFLAGS@
+
+# uncomment to build static executables from the example code
+#LDFLAGS = -all-static
+
+decoder_example_SOURCES = decoder_example.c
+decoder_example_LDADD = $(top_builddir)/lib/libvorbis.la @OGG_LIBS@
+
+encoder_example_SOURCES = encoder_example.c
+encoder_example_LDADD = $(top_builddir)/lib/libvorbisenc.la $(top_builddir)/lib/libvorbis.la @OGG_LIBS@
+
+chaining_example_SOURCES = chaining_example.c
+chaining_example_LDADD = $(top_builddir)/lib/libvorbisfile.la $(top_builddir)/lib/libvorbis.la @OGG_LIBS@
+
+vorbisfile_example_SOURCES = vorbisfile_example.c
+vorbisfile_example_LDADD = $(top_builddir)/lib/libvorbisfile.la $(top_builddir)/lib/libvorbis.la @OGG_LIBS@
+
+seeking_example_SOURCES = seeking_example.c
+seeking_example_LDADD = $(top_builddir)/lib/libvorbisfile.la $(top_builddir)/lib/libvorbis.la @OGG_LIBS@
+
+debug:
+ $(MAKE) all CFLAGS="@DEBUG@"
+
+profile:
+ $(MAKE) all CFLAGS="@PROFILE@"