summaryrefslogtreecommitdiffhomepage
path: root/contrib/ogg/src/Makefile.am
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2022-02-09 22:23:03 +0100
committerAki <please@ignore.pl>2022-02-09 22:53:55 +0100
commit373dc625f82b47096893add42c4472e4a57ab7eb (patch)
tree640228d02476d379de13071b13d1b1fa322b767f /contrib/ogg/src/Makefile.am
parent2d7dd844219965b81e81848e60d7f7bf23035ee4 (diff)
downloadstarshatter-373dc625f82b47096893add42c4472e4a57ab7eb.zip
starshatter-373dc625f82b47096893add42c4472e4a57ab7eb.tar.gz
starshatter-373dc625f82b47096893add42c4472e4a57ab7eb.tar.bz2
Moved third-party libraries to a separate subdirectory
Diffstat (limited to 'contrib/ogg/src/Makefile.am')
-rw-r--r--contrib/ogg/src/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/contrib/ogg/src/Makefile.am b/contrib/ogg/src/Makefile.am
new file mode 100644
index 0000000..9472626
--- /dev/null
+++ b/contrib/ogg/src/Makefile.am
@@ -0,0 +1,28 @@
+## Process this file with automake to produce Makefile.in
+
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include
+
+lib_LTLIBRARIES = libogg.la
+
+libogg_la_SOURCES = framing.c bitwise.c
+libogg_la_LDFLAGS = -no-undefined -version-info @LIB_CURRENT@:@LIB_REVISION@:@LIB_AGE@
+
+# build and run the self tests on 'make check'
+
+noinst_PROGRAMS = test_bitwise test_framing
+
+test_bitwise_SOURCES = bitwise.c
+test_bitwise_CFLAGS = -D_V_SELFTEST
+
+test_framing_SOURCES = framing.c
+test_framing_CFLAGS = -D_V_SELFTEST
+
+check: $(noinst_PROGRAMS)
+ ./test_bitwise$(EXEEXT)
+ ./test_framing$(EXEEXT)
+
+debug:
+ $(MAKE) all CFLAGS="@DEBUG@"
+
+profile:
+ $(MAKE) all CFLAGS="@PROFILE@"