summaryrefslogtreecommitdiffhomepage
path: root/contrib/Opcode/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2024-03-12 22:07:03 +0100
committerAki <please@ignore.pl>2024-03-12 22:07:36 +0100
commit81bb6873f1c0291fecbf6e429ad15ac3db66a4c0 (patch)
treefd7552ecabeeffb45a1fbe3730ab62bc7a64dd85 /contrib/Opcode/CMakeLists.txt
parentf43d32d6d2cc7ecd04f4f06f20d5a6fc2c87c9ae (diff)
downloadstarshatter-81bb6873f1c0291fecbf6e429ad15ac3db66a4c0.zip
starshatter-81bb6873f1c0291fecbf6e429ad15ac3db66a4c0.tar.gz
starshatter-81bb6873f1c0291fecbf6e429ad15ac3db66a4c0.tar.bz2
Legal notices updated
Rename contrib -> third-party intendes to express the origin and purpose of that part of the code better. I plan to readd contrib/ again but with more in-project things like bash-completions, dev workflow scripts etc.
Diffstat (limited to 'contrib/Opcode/CMakeLists.txt')
-rw-r--r--contrib/Opcode/CMakeLists.txt55
1 files changed, 0 insertions, 55 deletions
diff --git a/contrib/Opcode/CMakeLists.txt b/contrib/Opcode/CMakeLists.txt
deleted file mode 100644
index 6010c50..0000000
--- a/contrib/Opcode/CMakeLists.txt
+++ /dev/null
@@ -1,55 +0,0 @@
-project(Opcode)
-add_library(
- Opcode
- SHARED
- OPC_AABBCollider.cpp
- OPC_AABBTree.cpp
- OPC_BaseModel.cpp
- OPC_BoxPruning.cpp
- OPC_Collider.cpp
- OPC_Common.cpp
- OPC_HybridModel.cpp
- OPC_LSSCollider.cpp
- OPC_MeshInterface.cpp
- OPC_Model.cpp
- OPC_OBBCollider.cpp
- OPC_OptimizedTree.cpp
- OPC_Picking.cpp
- OPC_PlanesCollider.cpp
- OPC_RayCollider.cpp
- OPC_SphereCollider.cpp
- OPC_SweepAndPrune.cpp
- OPC_TreeBuilders.cpp
- OPC_TreeCollider.cpp
- OPC_VolumeCollider.cpp
- Opcode.cpp
- StdAfx.cpp
- Ice/IceAABB.cpp
- Ice/IceContainer.cpp
- Ice/IceHPoint.cpp
- Ice/IceIndexedTriangle.cpp
- Ice/IceMatrix3x3.cpp
- Ice/IceMatrix4x4.cpp
- Ice/IceOBB.cpp
- Ice/IcePlane.cpp
- Ice/IcePoint.cpp
- Ice/IceRandom.cpp
- Ice/IceRay.cpp
- Ice/IceRevisitedRadix.cpp
- Ice/IceSegment.cpp
- Ice/IceTriangle.cpp
- Ice/IceUtils.cpp
- )
-target_include_directories(
- Opcode
- PUBLIC ${CMAKE_CURRENT_SOURCE_DIR}
- )
-target_precompile_headers(
- Opcode
- PUBLIC StdAfx.h
- )
-target_compile_definitions(
- Opcode
- PRIVATE OPCODE_EXPORTS
- PUBLIC _ALLOW_KEYWORD_MACROS
- )