summaryrefslogtreecommitdiffhomepage
path: root/contrib/Opcode/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2022-02-09 22:23:03 +0100
committerAki <please@ignore.pl>2022-02-09 22:53:55 +0100
commit373dc625f82b47096893add42c4472e4a57ab7eb (patch)
tree640228d02476d379de13071b13d1b1fa322b767f /contrib/Opcode/CMakeLists.txt
parent2d7dd844219965b81e81848e60d7f7bf23035ee4 (diff)
downloadstarshatter-373dc625f82b47096893add42c4472e4a57ab7eb.zip
starshatter-373dc625f82b47096893add42c4472e4a57ab7eb.tar.gz
starshatter-373dc625f82b47096893add42c4472e4a57ab7eb.tar.bz2
Moved third-party libraries to a separate subdirectory
Diffstat (limited to 'contrib/Opcode/CMakeLists.txt')
-rw-r--r--contrib/Opcode/CMakeLists.txt55
1 files changed, 55 insertions, 0 deletions
diff --git a/contrib/Opcode/CMakeLists.txt b/contrib/Opcode/CMakeLists.txt
new file mode 100644
index 0000000..6010c50
--- /dev/null
+++ b/contrib/Opcode/CMakeLists.txt
@@ -0,0 +1,55 @@
+project(Opcode)
+add_library(
+ Opcode
+ SHARED
+ OPC_AABBCollider.cpp
+ OPC_AABBTree.cpp
+ OPC_BaseModel.cpp
+ OPC_BoxPruning.cpp
+ OPC_Collider.cpp
+ OPC_Common.cpp
+ OPC_HybridModel.cpp
+ OPC_LSSCollider.cpp
+ OPC_MeshInterface.cpp
+ OPC_Model.cpp
+ OPC_OBBCollider.cpp
+ OPC_OptimizedTree.cpp
+ OPC_Picking.cpp
+ OPC_PlanesCollider.cpp
+ OPC_RayCollider.cpp
+ OPC_SphereCollider.cpp
+ OPC_SweepAndPrune.cpp
+ OPC_TreeBuilders.cpp
+ OPC_TreeCollider.cpp
+ OPC_VolumeCollider.cpp
+ Opcode.cpp
+ StdAfx.cpp
+ Ice/IceAABB.cpp
+ Ice/IceContainer.cpp
+ Ice/IceHPoint.cpp
+ Ice/IceIndexedTriangle.cpp
+ Ice/IceMatrix3x3.cpp
+ Ice/IceMatrix4x4.cpp
+ Ice/IceOBB.cpp
+ Ice/IcePlane.cpp
+ Ice/IcePoint.cpp
+ Ice/IceRandom.cpp
+ Ice/IceRay.cpp
+ Ice/IceRevisitedRadix.cpp
+ Ice/IceSegment.cpp
+ Ice/IceTriangle.cpp
+ Ice/IceUtils.cpp
+ )
+target_include_directories(
+ Opcode
+ PUBLIC ${CMAKE_CURRENT_SOURCE_DIR}
+ )
+target_precompile_headers(
+ Opcode
+ PUBLIC StdAfx.h
+ )
+target_compile_definitions(
+ Opcode
+ PRIVATE OPCODE_EXPORTS
+ PUBLIC _ALLOW_KEYWORD_MACROS
+ )