summaryrefslogtreecommitdiffhomepage
path: root/contrib/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2024-03-06 21:47:34 +0100
committerAki <please@ignore.pl>2024-03-06 21:47:34 +0100
commita85fcbf8720562e77e0441ac26cb99d89564400c (patch)
treea15d30b7d00645685c50c291871d34aa5b188bc0 /contrib/CMakeLists.txt
parent54fa233a00607b9436c03c78b50b9107a33baa0a (diff)
parent1c558822681bbed5121bcc19816cbbac6a437b2a (diff)
downloadstarshatter-a85fcbf8720562e77e0441ac26cb99d89564400c.zip
starshatter-a85fcbf8720562e77e0441ac26cb99d89564400c.tar.gz
starshatter-a85fcbf8720562e77e0441ac26cb99d89564400c.tar.bz2
External projects with established upstream are no longer part of this source tree
Diffstat (limited to 'contrib/CMakeLists.txt')
-rw-r--r--contrib/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/contrib/CMakeLists.txt b/contrib/CMakeLists.txt
index 3939f0c..520ca73 100644
--- a/contrib/CMakeLists.txt
+++ b/contrib/CMakeLists.txt
@@ -1,9 +1,13 @@
+include(ApplyPatch)
+include(FetchContent)
+include(MakeAvailable)
add_subdirectory(libpng)
add_subdirectory(ogg)
-add_subdirectory(Opcode)
-add_subdirectory(sha1)
add_subdirectory(vorbis)
add_subdirectory(zlib)
+make_available(libpng ogg vorbis zlib)
+add_subdirectory(Opcode)
+add_subdirectory(sha1)
install(
TARGETS png15 Opcode zlib
RUNTIME