summaryrefslogtreecommitdiffhomepage
path: root/Opcode/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2021-09-30 10:48:15 +0200
committerAki <please@ignore.pl>2021-09-30 10:48:15 +0200
commitadb8f1fcf0172c4c4299703efea1d0744d03b5e7 (patch)
treef2424a6514df2ac53fcb86604ffb5075c75df62e /Opcode/CMakeLists.txt
parent21b5090ea35426c2b322bf05cb1025e6e5cc5742 (diff)
downloadstarshatter-adb8f1fcf0172c4c4299703efea1d0744d03b5e7.zip
starshatter-adb8f1fcf0172c4c4299703efea1d0744d03b5e7.tar.gz
starshatter-adb8f1fcf0172c4c4299703efea1d0744d03b5e7.tar.bz2
Added Opcode to cmake tree
Diffstat (limited to 'Opcode/CMakeLists.txt')
-rw-r--r--Opcode/CMakeLists.txt54
1 files changed, 54 insertions, 0 deletions
diff --git a/Opcode/CMakeLists.txt b/Opcode/CMakeLists.txt
new file mode 100644
index 0000000..020830f
--- /dev/null
+++ b/Opcode/CMakeLists.txt
@@ -0,0 +1,54 @@
+project(Opcode)
+add_library(
+ Opcode
+ SHARED
+ OPC_AABBCollider.cpp
+ OPC_AABBTree.cpp
+ OPC_BaseModel.cpp
+ OPC_BoxPruning.cpp
+ OPC_Collider.cpp
+ OPC_Common.cpp
+ OPC_HybridModel.cpp
+ OPC_LSSCollider.cpp
+ OPC_MeshInterface.cpp
+ OPC_Model.cpp
+ OPC_OBBCollider.cpp
+ OPC_OptimizedTree.cpp
+ OPC_Picking.cpp
+ OPC_PlanesCollider.cpp
+ OPC_RayCollider.cpp
+ OPC_SphereCollider.cpp
+ OPC_SweepAndPrune.cpp
+ OPC_TreeBuilders.cpp
+ OPC_TreeCollider.cpp
+ OPC_VolumeCollider.cpp
+ Opcode.cpp
+ StdAfx.cpp
+ Ice/IceAABB.cpp
+ Ice/IceContainer.cpp
+ Ice/IceHPoint.cpp
+ Ice/IceIndexedTriangle.cpp
+ Ice/IceMatrix3x3.cpp
+ Ice/IceMatrix4x4.cpp
+ Ice/IceOBB.cpp
+ Ice/IcePlane.cpp
+ Ice/IcePoint.cpp
+ Ice/IceRandom.cpp
+ Ice/IceRay.cpp
+ Ice/IceRevisitedRadix.cpp
+ Ice/IceSegment.cpp
+ Ice/IceTriangle.cpp
+ Ice/IceUtils.cpp
+ )
+target_include_directories(
+ Opcode
+ PRIVATE .
+ )
+target_precompile_headers(
+ Opcode
+ PUBLIC StdAfx.h
+ )
+target_compile_definitions(
+ Opcode
+ PUBLIC OPCODE_EXPORTS
+ )