summaryrefslogtreecommitdiffhomepage
path: root/NetEx/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2021-09-30 16:49:25 +0200
committerAki <please@ignore.pl>2021-09-30 16:49:25 +0200
commit545889c990d9155635dfca73345be37f207b2d68 (patch)
tree8133da0fdf1db86489ed84403f56afef6c6a56e1 /NetEx/CMakeLists.txt
parent966fe28c59f59fc8be795c8215b9352435982445 (diff)
downloadstarshatter-545889c990d9155635dfca73345be37f207b2d68.zip
starshatter-545889c990d9155635dfca73345be37f207b2d68.tar.gz
starshatter-545889c990d9155635dfca73345be37f207b2d68.tar.bz2
Fixed NetEx includes against win sdk
Diffstat (limited to 'NetEx/CMakeLists.txt')
-rw-r--r--NetEx/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/NetEx/CMakeLists.txt b/NetEx/CMakeLists.txt
index 553ab30..ccb0f01 100644
--- a/NetEx/CMakeLists.txt
+++ b/NetEx/CMakeLists.txt
@@ -17,9 +17,11 @@ add_library(
NetServer.cpp
NetSock.cpp
)
+set(WINDOWSSDK_PATH "C:/Program Files (x86)/Windows Kits/10/Include/10.0.19041.0/um")
target_include_directories(
NetEx
- PUBLIC .
+ PUBLIC ${CMAKE_CURRENT_SOURCE_DIR}
+ PUBLIC ${WINDOWSSDK_PATH} # FIXME
)
target_link_libraries(
NetEx