summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2021-09-28 21:51:34 +0200
committerAki <please@ignore.pl>2021-09-28 21:51:34 +0200
commitf9bc90d009d7c96d97e4bfa7a5679e01dddd5dfd (patch)
treef96b45323d384ec41e4d6cd3fdce42b2cfe0332b /CMakeLists.txt
parent3a507e08b1d4e5970b27401a7e6517570d529400 (diff)
downloadstarshatter-f9bc90d009d7c96d97e4bfa7a5679e01dddd5dfd.zip
starshatter-f9bc90d009d7c96d97e4bfa7a5679e01dddd5dfd.tar.gz
starshatter-f9bc90d009d7c96d97e4bfa7a5679e01dddd5dfd.tar.bz2
Created best-guess cmake stubs
Structure of the project as whole is... questionable. It looks that the directories are intermingled even if they appear separated. This is a first guess to have at least something in place.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..aa56f7f
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,16 @@
+cmake_minimum_required(VERSION 3.21)
+project(Starshatter)
+add_subdirectory(Datafile)
+# /DirectX contains only pre-compiled third-party library (and looks like a workaround).
+# /Doc contains various documentation and pre-generated Doxygen docs.
+add_subdirectory(FoundationEx)
+# add_subdirectory(libpng) # is a third-party library.
+add_subdirectory(Magic2)
+add_subdirectory(NetEx)
+add_subdirectory(nGenEx)
+# /oggvorbis contains only pre-compiled third-party library.
+# add_subdirectory(Opcode) # is a third-party library.
+# /Parser looks unused.
+add_subdirectory(Stars45)
+# /Starshatter contains VS-related files.
+# add_subdirectory(zlib) # is a third-party library.