summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAki <please@ignore.pl>2021-10-02 20:44:33 +0200
committerAki <please@ignore.pl>2021-10-02 21:07:09 +0200
commite9c3d5411eac83a9263fe911d9e946b17c1e966e (patch)
treed46321be037ec251e67476e0b8c43b7fc6afbc1e /CMakeLists.txt
parentb8018588d27e84fb6679ec22aa907bdfdc8b6e88 (diff)
downloadstarshatter-e9c3d5411eac83a9263fe911d9e946b17c1e966e.zip
starshatter-e9c3d5411eac83a9263fe911d9e946b17c1e966e.tar.gz
starshatter-e9c3d5411eac83a9263fe911d9e946b17c1e966e.tar.bz2
Enabled C++11 standard with extensions
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e4ddfcb..286f0ea 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,6 @@
cmake_minimum_required(VERSION 3.20)
+set(CMAKE_CXX_STANDARD 11)
+set(CMAKE_CXX_EXTENSIONS Yes)
project(Starshatter)
set(WINDOWSSDK_LIBPATH "C:/Program Files (x86)/Windows Kits/10/Lib/10.0.19041.0" CACHE FILEPATH "Path to a versioned lib directory of selected Windows SDK")
set(WINDOWSSDK_PATH "C:/Program Files (x86)/Windows Kits/10/Include/10.0.19041.0" CACHE FILEPATH "Path to a versioned include directory of selected Windows SDK")